bashの脆弱性Shell Shockをチェック


bashの脆弱性「Shell Shock」。

関連リンク:bashの脆弱性(CVE-2014-6271) #ShellShock の関連リンクをまとめてみた

これに関する対応が必要かどうかチェックしてみました。

参考にしたのは、bash の脆弱性 “Shell Shock” のめっちゃ細かい話 (CVE-2014-6271) 

こちらの記事にあるコマンド

 $ env x='() { :;}; echo vulnerable’ bash -c “echo this is a test”

上記のコマンドを実行し

vulnerable
this is a test

上記のような結果が表示されれば脆弱性ありと言うことです。

そして実行結果ですが

# env =() { :;}; echo vulnerable bash echo this is a test
-bash: syntax error near unexpected token `(‘

エラーでコマンドを実行出来ませんでした。

どうやらこちらで使用している環境のbashには脆弱性は無かった模様です。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

次のHTML タグと属性が使えます: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>